Rounding the last digit of value in CSV format

Hi All,
I have an issue with the downloading results in CSV format. I have a field with string data type and has value as 04100380138378381. But when I try to download the data in CSV it gets in 4100380138378380.

I did saw one option to “Quote numeric strings in CSV downloads” and it helps to get the right values in csv by keeping Quote as ‘04100380138378381’, but user has to remove that quote all the time before he/she uses it.
Is there any other way, I could follow to get the values in CSV format with out rounding off.

Thank you,
Ganesh

@Ganesh have you tried the Excel download option for this use-case? It may work better now in later versions of Arcadia (version 5.1.3 and later) if you have access to that.

@taddwood, yes that is the only option I have. But it does not work if at all, we have to automate report output through schedule job with xls format because even with Arcadia latest version(5.1.3) does support to send the scheduled output in xls format.

Thank you,
Ganesh