Issue when downgrading from Arcadia 4.3+ to 4.2 and lower: Unsupported pickle protocol: 4

If you attempt to downgrade from Arcadia 4.3 (and greater) to Arcadia 4.2 (and lower), you might see an error like this after restarting Arcadia Visualization Server:

19%20PM_edit

The upgrade to Arcadia 4.3+ included an upgrade to Python 3.6 (from Python 2.7), which will cause an issue when the Arcadia Visualization Server cache tries to serialize results in an older version of Python. To fix the issue, just clear the Arcadia cache directory and then restart Arcadia Visualization Server:

rm -rf /var/lib/arcadia/cache/*

1 Like